26 lines
404 B
Nix
26 lines
404 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
with lib; {
|
|
services = {
|
|
nginx = {
|
|
virtualHosts."status.posixlycorrect.com" = {
|
|
enableACME = true;
|
|
forceSSL = true;
|
|
locations."/" = {
|
|
proxyPass = "http://127.0.0.1:4456";
|
|
};
|
|
};
|
|
};
|
|
uptime-kuma = {
|
|
enable = true;
|
|
settings = {
|
|
HOST = "127.0.0.1";
|
|
PORT = "4456";
|
|
};
|
|
};
|
|
};
|
|
}
|