30 lines
530 B
Nix
30 lines
530 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
with lib; {
|
|
services = {
|
|
nginx = {
|
|
virtualHosts."status.posixlycorrect.com" = {
|
|
enableACME = true;
|
|
forceSSL = true;
|
|
extraConfig = ''
|
|
proxy_headers_hash_max_size 512;
|
|
proxy_headers_hash_bucket_size 128;
|
|
'';
|
|
locations."/" = {
|
|
proxyPass = "http://127.0.0.1:4456";
|
|
};
|
|
};
|
|
};
|
|
uptime-kuma = {
|
|
enable = true;
|
|
settings = {
|
|
HOST = "127.0.0.1";
|
|
PORT = "4456";
|
|
};
|
|
};
|
|
};
|
|
}
|