218 lines
6 KiB
Nix
218 lines
6 KiB
Nix
{ lib, vscode-utils, vscode-extensions }: with vscode-utils; {
|
|
extensions = {
|
|
inherit (vscode-extensions.bbenoist) nix;
|
|
inherit (vscode-extensions.ms-vscode) cpptools;
|
|
|
|
rust = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "rust-lang";
|
|
name = "rust";
|
|
version = "0.7.8";
|
|
sha256 = "sha256-Y33agSNMVmaVCQdYd5mzwjiK5JTZTtzTkmSGTQrSNg0=";
|
|
};
|
|
meta.license = lib.licenses.mit;
|
|
};
|
|
|
|
indenticator = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "sirtori";
|
|
name = "indenticator";
|
|
version = "0.7.0";
|
|
sha256 = "sha256-J5iNO6V5US+GFyNjNNA5u9H2pKPozWKjQWcLAhl+BjY=";
|
|
};
|
|
meta.license = lib.licenses.mit;
|
|
};
|
|
|
|
matlab = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "Gimly81";
|
|
name = "matlab";
|
|
version = "2.3.1";
|
|
sha256 = "sha256-0vx5L9efxvubb+JFunJJKaPvSxfgmYZkDJOxpXAV6xs=";
|
|
};
|
|
meta.license = lib.licenses.mit;
|
|
};
|
|
|
|
octave = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "toasty-technologies";
|
|
name = "octave";
|
|
version = "0.0.3";
|
|
sha256 = "sha256-tbqblaBX+wqgasfGLsFp49xYxXi5CF39YPYs0QyANt0=";
|
|
};
|
|
};
|
|
|
|
riscv = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "zhwu95";
|
|
name = "riscv";
|
|
version = "0.0.8";
|
|
sha256 = "sha256-PXaHSEXoN0ZboHIoDg37tZ+Gv6xFXP4wGBS3YS/53TY=";
|
|
};
|
|
};
|
|
|
|
pdf = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "tomoki1207";
|
|
name = "pdf";
|
|
version = "1.2.0";
|
|
sha256 = "sha256-/2u2yfAmSVBvfXIMt2VokkeYH8q8Y9Ca9YSDuwwpkq0=";
|
|
};
|
|
};
|
|
|
|
vscode-icons = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "vscode-icons-team";
|
|
name = "vscode-icons";
|
|
version = "12.0.0";
|
|
sha256 = "sha256-TQ/GPxNgbMBVlp+KNRd+M0vMxFSAjld/CCbVS9C1DuA=";
|
|
};
|
|
};
|
|
|
|
arm = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "dan-c-underwood";
|
|
name = "arm";
|
|
version = "1.7.4";
|
|
sha256 = "sha256-gZBM980AoD+0wnfHXJK9sqCuuLtRY08JnO3Qdq/TRfc=";
|
|
};
|
|
};
|
|
|
|
verilogHDL = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "mshr-h";
|
|
name = "VerilogHDL";
|
|
version = "1.5.4";
|
|
sha256 = "sha256-WxVEP37Z+hATTOZSozYSSGtDUSMKAO/nA6ORXbpjGMU=";
|
|
};
|
|
};
|
|
|
|
tcl = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "rashwell";
|
|
name = "tcl";
|
|
version = "0.1.0";
|
|
sha256 = "sha256-k8I/W3g98r/YCyIURgm7hh+0Bm0lg4Mdh/r8HsPSoX0=";
|
|
};
|
|
};
|
|
|
|
txt-syntax = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "xshrim";
|
|
name = "txt-syntax";
|
|
version = "0.2.1";
|
|
sha256 = "sha256-5MOHyTHAefD4X9dpMCJ1ArxBqvHRLfFjENXkIPmAw4M=";
|
|
};
|
|
};
|
|
|
|
linkerscript = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "ZixuanWang";
|
|
name = "linkerscript";
|
|
version = "1.0.2";
|
|
sha256 = "sha256-J6j4tXJ+gQWGJnMiqoIqJT2kGs/m8Njjm9pX9NCvJWc=";
|
|
};
|
|
};
|
|
|
|
vscode-drawio = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "hediet";
|
|
name = "vscode-drawio";
|
|
version = "1.6.4";
|
|
sha256 = "sha256-+VYdFk9VCp3KnvOASJ+jJSb1NBwykBlnd8EuSKw8sKI=";
|
|
};
|
|
};
|
|
|
|
better-comments = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "aaron-bond";
|
|
name = "better-comments";
|
|
version = "3.0.2";
|
|
sha256 = "sha256-hQmA8PWjf2Nd60v5EAuqqD8LIEu7slrNs8luc3ePgZc=";
|
|
};
|
|
};
|
|
|
|
code-spell-checker = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "streetsidesoftware";
|
|
name = "code-spell-checker";
|
|
version = "2.10.1";
|
|
sha256 = "sha256-FeYkSML6QYtuIHIbAovOqlPwkKfNkHr7IdMCWwkynQ0=";
|
|
};
|
|
};
|
|
|
|
vscode-todo-highlight = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "wayou";
|
|
name = "vscode-todo-highlight";
|
|
version = "1.0.5";
|
|
sha256 = "sha256-CQVtMdt/fZcNIbH/KybJixnLqCsz5iF1U0k+GfL65Ok=";
|
|
};
|
|
};
|
|
|
|
clang-format = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "xaver";
|
|
name = "clang-format";
|
|
version = "1.9.0";
|
|
sha256 = "sha256-q9DvkXbv+GTyeMVIyUQDK49Njsl9msbnOD1gyS4ljC8=";
|
|
};
|
|
};
|
|
|
|
markdown-all-in-one = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "yzhang";
|
|
name = "markdown-all-in-one";
|
|
version = "3.4.4";
|
|
sha256 = "sha256-2lZfWP+yk0Dp8INLjlJY5ROGu0sLaWhb4fT+O9xGg0s=";
|
|
};
|
|
};
|
|
|
|
path-intellisense = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "christian-kohler";
|
|
name = "path-intellisense";
|
|
version = "2.8.1";
|
|
sha256 = "sha256-lTKzMphkGgOG2XWqz3TW2G9sISBc/kG7oXqcIH8l+Mg=";
|
|
};
|
|
};
|
|
|
|
wav-preview = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "sukumo28";
|
|
name = "wav-preview";
|
|
version = "2.0.4";
|
|
sha256 = "sha256-N7Scz3vjDws4oTMqrM3mSANeW85GGpBUY2xfZx+WezY=";
|
|
};
|
|
};
|
|
|
|
indent-rainbow = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "oderwat";
|
|
name = "indent-rainbow";
|
|
version = "8.3.1";
|
|
sha256 = "sha256-dOicya0B2sriTcDSdCyhtp0Mcx5b6TUaFKVb0YU3jUc=";
|
|
};
|
|
};
|
|
|
|
python = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "ms-python";
|
|
name = "python";
|
|
version = "2022.19.13141010";
|
|
sha256 = "sha256-8LbjpXLAAwK/oEPwpX+N1sWkSFNzQfWAkaBEQr49SQk=";
|
|
};
|
|
};
|
|
|
|
language-x86-64-assembly = buildVscodeMarketplaceExtension {
|
|
mktplcRef = {
|
|
publisher = "13xforever";
|
|
name = "language-x86-64-assembly";
|
|
version = "3.0.0";
|
|
sha256 = "sha256-wIsY6Fuhs676EH8rSz4fTHemVhOe5Se9SY3Q9iAqr1M=";
|
|
};
|
|
};
|
|
};
|
|
}
|
|
# para obtener el sha: lib.fakeSha256
|