90 lines
2 KiB
Nix
90 lines
2 KiB
Nix
{ config, lib, pkgs, ... } :
|
|
with lib;
|
|
{
|
|
programs = {
|
|
zsh = {
|
|
enable = true;
|
|
syntaxHighlighting.enable = true;
|
|
initExtra = import ./zshrc.nix pkgs;
|
|
};
|
|
git = {
|
|
enable = true;
|
|
userEmail = "fabian@cluster451.org";
|
|
userName = "Fabián Montero";
|
|
signing.key = "E77A808BF9A955D668EEEA6473FA9C9CB5F0249B";
|
|
extraConfig.init.defaultBranch = "main";
|
|
};
|
|
helix = {
|
|
enable = true;
|
|
settings = {
|
|
# theme = "onedark";
|
|
editor = {
|
|
mouse = true;
|
|
line-number = "absolute";
|
|
cursorline = true;
|
|
cursorcolumn = true;
|
|
gutters = [ "diagnostics" "spacer" "line-numbers" "diff" ];
|
|
auto-completion = true;
|
|
auto-format = true;
|
|
auto-save = true;
|
|
bufferline = "multiple";
|
|
rulers = [ 80 ];
|
|
true-color = true;
|
|
lsp.display-messages = true;
|
|
auto-pairs = false;
|
|
whitespace = {
|
|
render = {
|
|
space = "all";
|
|
nbsp = "all";
|
|
tab = "all";
|
|
newline = "none";
|
|
};
|
|
|
|
};
|
|
indent-guides = {
|
|
character = "╎";
|
|
render = true;
|
|
};
|
|
cursor-shape = {
|
|
select = "block";
|
|
insert = "block";
|
|
normal = "block";
|
|
};
|
|
statusline = {
|
|
left = [ "mode" "spinner" "version-control" "file-name" "file-modification-indicator" "total-line-numbers" ];
|
|
};
|
|
file-picker = {
|
|
hidden = false;
|
|
follow-symlinks = false;
|
|
deduplicate-links = false;
|
|
|
|
};
|
|
};
|
|
keys.normal = {
|
|
space.space = "file_picker";
|
|
space.w = ":w";
|
|
space.q = ":q";
|
|
esc = [ "collapse_selection" "keep_primary_selection" ];
|
|
};
|
|
};
|
|
};
|
|
};
|
|
|
|
home.packages = with pkgs;
|
|
[
|
|
calc
|
|
file
|
|
gcc
|
|
htop
|
|
killall
|
|
man-pages
|
|
man-pages-posix
|
|
rar
|
|
tree
|
|
units
|
|
unzip
|
|
usbutils
|
|
zip
|
|
];
|
|
}
|