t14_legacy_config/home/default.nix
Fabian Montero 94b184cb69 last commit
2024-12-02 20:51:02 -06:00

65 lines
1.2 KiB
Nix

{ self, nixpkgs, unstable, hm-isolation, nixGL }:
{ config, pkgs, lib, ... } :
with lib;
{
imports = [
(hm-isolation.homeManagerModule)
./apps
./allowUnfreeWhitelist.nix
./gui
./isolation.nix
./options.nix
./cli.nix
./systemd
];
nixpkgs.overlays = [ self.overlay nixGL.overlay ];
home = {
stateVersion = "21.11"; # No tocar esto
username = "fabian";
homeDirectory = "/home/fabian";
sessionVariables = {
"EDITOR" = "nvim";
"TERMINAL" = "kitty";
};
keyboard = {
layout = "us";
variant = "altgr-intl";
};
};
nix.registry = {
"system".to = {
type = "path";
path = "/home/fabian/nix";
};
"nixpkgs".flake = nixpkgs;
"unstable".flake = unstable;
};
services.gpg-agent = {
enable = true;
enableZshIntegration = true;
pinentryFlavor = "gtk2";
};
programs.home-manager.enable = true;
xdg = {
enable = true;
configFile."nixpkgs".source = config.lib.file.mkOutOfStoreSymlink config.nix.registry."system".to.path;
};
local = {
apps.enable = mkDefault (!config.home.isolation.active);
gui = {
enable = mkDefault true;
desktop = mkDefault (!config.home.isolation.active);
};
};
}