28 lines
462 B
Nix
28 lines
462 B
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
with lib; let
|
|
cfg = config.local.sys.graphics;
|
|
in {
|
|
options.local.sys.graphics = {
|
|
enable = mkEnableOption "graphics settings";
|
|
};
|
|
config = mkIf cfg.enable {
|
|
services = {
|
|
xserver = {
|
|
enable = true;
|
|
xkb.layout = "us";
|
|
displayManager.startx.enable = true;
|
|
};
|
|
libinput.enable = true;
|
|
};
|
|
|
|
hardware.graphics.enable = true;
|
|
|
|
programs.dconf.enable = true;
|
|
};
|
|
}
|